snagit mp4 datei

Das alte Hilfeformat von Microsoft
Antworten
Newcomer65
Beiträge: 13
Registriert: Fr Aug 14, 2020 10:58

snagit mp4 datei

Beitrag von Newcomer65 »

Hallo zusammen

wie bette ich eine mp4 Datei richtig ein.
Bei mir kommt die Meldung:
"Die Videodatei ....mp4 muß mit der Hilfe separat ausgeliefert werden und ist nicht eingebettet."
Nach dem Build kann man die Videos nicht abspielen. Webhelp Ausgabe.
Das ist nicht bei allen Videos. Aber bei einigen. Haben alle drumrum den gleichen Code und haben alle das gleiche Format mp4 und sind alle mit Snagit erstellt worden. Warum funktionieren einige und andere nicht?
Sie werden angezeigt, aber beim Drücken auf den Startbutton passiert nichts.
Danke!

Benutzeravatar
Jörg Ertelt
Moderator
Beiträge: 2724
Registriert: Do Dez 22, 2005 21:28

Re: snagit mp4 datei

Beitrag von Jörg Ertelt »

Besteht das Problem noch?
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Lizenzen kaufen / upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HELPDESIGN • JÖRG ERTELT
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Newcomer65
Beiträge: 13
Registriert: Fr Aug 14, 2020 10:58

Re: snagit mp4 datei

Beitrag von Newcomer65 »

Hallo Jörg
Danke für Deine Nachricht.
MP4 Dateien funktionieren nun. Geändert wurde: Ausgabe inline und neue HelpManual Version aufgespielt.
Helpxplain funktioniert nicht. Die Dateien liegen auf dem Server, werden aber leider nach dem Build nicht mit ausgegeben. Es erscheint nichts.
Es müsste doch für die WebHelp-ausgabe reichen, die helpxplain Dateien einzufügen. Lokal funktioniert ja auch alles. Aber sobald ein Build gemacht wird, gibt es teilweise statt helpxplain ein leerer Platz. Dieses Problem habe ich auch bei der Augabe von Listen der untergeordneten Topics (also auch Objekte). Habe ich eventuell ein grundsätzliches Problem mit bestimmten Objekten?
Stand:
Dateien sind alle vorhanden (helpxplain-Dateien liegen auf dem entsprechenden Server)
Verlinkung gecheckt (im code, alle relativ)
HelpManual: aktuelle Version
HelpXPlain: aktuelle Version, eingebunden in HelpManual

Freue mich auf Ideen :-)

Benutzeravatar
Jörg Ertelt
Moderator
Beiträge: 2724
Registriert: Do Dez 22, 2005 21:28

Re: snagit mp4 datei

Beitrag von Jörg Ertelt »

Guten Tag Newcomer65,

Ich habs mal kurz getestet.

HelpXplain-Projekt liegt auf dem Server, H+M-Projekt lokal.
HelpXplain-Projekt mit H+M via Einfügen > Einfügen > Medien > HelpXPlain eingefügt.
WebHelp erzeugt. WH öffnete aus H+M. Ergebnis: Inhalt vom HelpXplain-Projekt wird angezeigt.
Dann in der HTML-Ausgabe nachgesehen: xplain-Ordner mit Inhalt vorhanden. Dieser Inhalt kann auch separat im Browser geöffnet werden.
HTML-Ausgabe auf Server gelegt und geöffnet: HelpXplain-Inhalt wird einwandfrei angezeigt.

Bitte prüfen, ob in der HTML-Ausgabe der xplain-Ordner mit Inhalt enthalten ist.

Falls ja, den gesamten HTML-Ordner in ein lokales Verzeichnis kopieren und die HTML-Ausgabe im Browser öffnen.

Wenn der Inhalt angezeigt wird, liegts ggf. an Sicherheitseinstellungen im Browser.
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Lizenzen kaufen / upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HELPDESIGN • JÖRG ERTELT
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Newcomer65
Beiträge: 13
Registriert: Fr Aug 14, 2020 10:58

Re: snagit mp4 datei

Beitrag von Newcomer65 »

Hallo Jörg
das wäre eine Idee!
Wenn ich lokal ausgebe, dann wird ein Ordner xplain automatisch angelegt.
Auf dem besagten Server habe ich diese nicht gefunden.
Aber: wenn eine Ausgabe WEBHELP generiert wird, gebe ich eine Ausgabedatei an. Webhelp/Indexseite/Vorlage auswählen. Die Indexseite ist in diesem Fall für alle Dateien. Könnte ich es steuern, dass die helpxplain-Datein (die normalerweise im Ordner xplain sind) eben nicht in einem neuen Ordner angelegt werden?
Wenn dies nicht der Fall ist:
Verlinke ich dann das Objekt (xplain-Datei) auf eine HTML-Seite. Also statt C:\.....\Se.....xplain auf C:\...\...Html\Datei.html?
Oder kann ich den lokal generierten xplain-Ordner direkt auf den Server schieben? Oder gibt dies bei der Neugenerierung Probleme?
Gruss

Benutzeravatar
Jörg Ertelt
Moderator
Beiträge: 2724
Registriert: Do Dez 22, 2005 21:28

Re: snagit mp4 datei

Beitrag von Jörg Ertelt »

Dann ist mein Latein am Ende.
Bei mir klappt das, egal wo das H+M- bzw. HelpXplain-Projekt liegt. Es wird immer ein xplain-Ordner angelegt. Vielleicht ein Problem fehlender Schreibrechte?

==
Verlinke ich dann das Objekt (xplain-Datei) auf eine HTML-Seite
==

Ein HelpXplain-Objekt (.xplain) wird in ein Topic eingefügt mit Einfügen > Einfügen > Medien > HelpXPlain. Das erzeugt einen Link zum Objekt. Der relative Pfad wird in H+M unter Konfiguration > Allgemeine Einstellungen > Projekt-Suchpfad eingetragen.
Ggf. fehlt dort der Pfad. Der kann manuell hinzugefügt werden
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Lizenzen kaufen / upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HELPDESIGN • JÖRG ERTELT
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Newcomer65
Beiträge: 13
Registriert: Fr Aug 14, 2020 10:58

Re: snagit mp4 datei

Beitrag von Newcomer65 »

Dennoch Danke
Pfad ist schon angegeben und Objekt wurde so hinzugefügt, wie Sie beschrieben haben.

Viele Grüße

Benutzeravatar
Jörg Ertelt
Moderator
Beiträge: 2724
Registriert: Do Dez 22, 2005 21:28

Re: snagit mp4 datei

Beitrag von Jörg Ertelt »

Vielleicht noch ein Ansatz: Was meinen Sie mit "Server"? Ist das ein Websever, auf dem Sie die WebHelp samt HelpXplain veröffentlichen? Oder ist das ein Server zur Ablage von Dateien im Unternehmen, auf den Sie z. B. via Windows-Explorer zugreifen?

Sollte es sich um einen Webserver handeln liegt die Vermutung nahe, dass Sie nicht alles veröffentlich haben. Wenn Sie mit H+M eine Webhelp-Ausgabe erzeugen, liegt diese ja zunächst lokal. In dieser lokalen Webhelp-Ausgabe gibt es einen Unterordner xplain. Sollte der auf dem Webserver fehlen, wurde er dort eben nicht veröffentlicht. Wobei das nicht logisch ist: Wenn nämlich der Ordner mit der Webhelp-Ausgabe auf dem Server veröffentlicht wird, sollte auch der Unterordner xplain veröffentlicht werden.
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Lizenzen kaufen / upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HELPDESIGN • JÖRG ERTELT
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Newcomer65
Beiträge: 13
Registriert: Fr Aug 14, 2020 10:58

Re: snagit mp4 datei

Beitrag von Newcomer65 »

Hallo Jörg
Problem besteht leider immer noch.
wenn HelpManual als Dienst läuft...auf was müssen wir achten?
Viele Grüße

Benutzeravatar
Jörg Ertelt
Moderator
Beiträge: 2724
Registriert: Do Dez 22, 2005 21:28

Re: snagit mp4 datei

Beitrag von Jörg Ertelt »

Was meinen Sie mit "Server"? Ist das ein Websever, auf dem Sie die WebHelp samt HelpXplain veröffentlichen? Oder ist das ein Server zur Ablage von Dateien im Unternehmen, auf den Sie z. B. via Windows-Explorer zugreifen?

==
wenn HelpManual als Dienst läuft...auf was müssen wir achten?
==

Was meinen Sie mit "HelpManual als Dienst läuft"?
Wo veröffentlichen Sie die Webhelp-Ausgabe, siehe erster Satz oben?

Hellsehen kann ich leider nicht und ohne handfeste Informationen kann ich mich nicht äußern.
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Lizenzen kaufen / upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HELPDESIGN • JÖRG ERTELT
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Alexander Halser
Beiträge: 276
Registriert: Fr Dez 23, 2005 10:27

Re: snagit mp4 datei

Beitrag von Alexander Halser »

wenn HelpManual als Dienst läuft...auf was müssen wir achten?
Aus dem Thread oben ist mir noch nicht ganz klar, was eigentlich genau nicht funktioniert bei Ihnen.

Generell ist es so, daß Help+Manual 8 einen HelpXplain-Compiler mitbringt, es kann also .Xplain-Dateien lesen und die HTML-Ausgabe davon generieren, unabhängig davon ob HelpXplain selbst auf dem Rechner installiert ist oder nicht. Nur zum Bearbeiten der .Xplain-Dateien ist HelpXplain selbst notwendig. Webhelp erzeugen kann Help+Manual auch ganz alleine, auch Webhelp mit eingebetteten Xplains.

Wichtig: Help+Manual v7 hatte noch keinen eigenen Xplain-Compiler mit dabei, Version 8 schon.

Das Erzeugen von Webhelp sollte also auf jeden Fall funktionieren und wenn ich den Thread oben richtig lese, dann werden die Xplains auch im Webhelp-Ausgabeordner erzeugt. Ist das soweit richtig?

Beim Erzeugen von Webhelp erhalten Sie folgende Ordner-Strukur (vereinfacht):

Code: Alles auswählen

\WebhelpOrdner     <= enthält alle Webhelp HTML Dateien, Bilder, Javascripts, etc.
\WebhelpOrdner\xplain    <= Alle Xplains im Projekt landen in diesem Ordner, Name ist fix

Der Unterordner \WebhelpAusgabeOrdner\xplain\ enthält weitere Unter-Ordner, und zwar pro Xplain einen. Plus einen Unterordner für die Javascript-Dateien, welche von allen Xplains gemeinsam genutzt werden. Der komplette Webhelp-Ausgabeordner hat also ungefähr diese Strukur mitsamt den Unterverzeichnissen:

Code: Alles auswählen

\WebhelpOrdner
\WebhelpOrdner\xplain
\WebhelpOrdner\xplain\meinxplain1
\WebhelpOrdner\xplain\meinxplain2
\WebhelpOrdner\xplain\meinxplain3
\WebhelpOrdner\xplain\js
Wenn Sie nun Webhelp lokal aufrufen und ein Topic laden, in dem ein Xplain eingebaut ist, funktioniert das?

Wenn das funktioniert, hat alles geklappt. Nur: wo funktioniert es bei Ihnen nicht mehr?
Um die Webhelp-Ausgabe auf Ihrem Webserver zu veröffentlichen, müssen Sie den Ordner "\WebhelpOrdner" einschließlich aller Unterverzeichnisse und aller Dateien auf den Webserver raufladen. Überprüfen Sie nach dem Upload, ob die Verzeichnisstruktur am Webserver genauso aussieht wie lokal. Funktioniert das und wurde alles samt Unterverzeichnissen hochgeladen?

Wenn ja, muß es auch am Webserver funktionieren. Dem Thread oben zufolge gewinne ich den Eindruck als ob das Hochladen der Unterverzeichnisse auf den Webserver nicht geklappt hat.
Alexander Halser
Help+Manual Support und Entwicklung
www.helpandmanual.com

Antworten