Externe Dateien aus .chm-Dateien öffnen

Das alte Hilfeformat von Microsoft
Antworten
Benutzeravatar
Jörg Ertelt
Moderator
Beiträge: 2646
Registriert: Do Dez 22, 2005 21:28

Externe Dateien aus .chm-Dateien öffnen

Beitrag von Jörg Ertelt »

Die nachfolgende Beschreibung bezieht sich auf Help & Manual Version 4! (Es funktioniert auch mit HuM5, allerdings finden sich einige Einstellungen an anderer Stelle)



Liebe Forums-Leser,



es geht mal wieder um das leidige Thema "externe Dateien, vorzugsweise PDF, aus einer .chm-Datei öffnen". Analog gilt dieser Anspruch für jeden anderen Dateityp.



Zur Umsetzung gibt es unterschiedliche Lösungen: Shortcuts (ActiveX Controls), JavaScripte und anderes. Mal funktioniert die eine, mal die andere Lösung. Oder eben auch nicht. Insbesondere seit SP2 unter Windows XP eingeführt wurde, ging die Malaise richtig los.



Ich habe nun eine Lösung gefunden, die auf JScript (Microsoft Derrivat von JavaScript) basiert und immun zu sein scheint gegenüber diversen Microsoft-Patches. Weiterer Vorteil: Es wird kein Downloadfenster angezeigt, jedenfalls nicht bei PFD und die Dateien werden gemäß meinen Tests im .chm-Viewer anstelle des jeweiligen Topics geöffnet. Konnte das verifizieren für PDF- und Word-Dateien.



Die Zutaten zur Umsetzung der Lösung:

* eine JavaScript-Datei mit JScript-Funktionen

* eine Masterpage

* einen JavaScript-Aufruf

* externen Dateien beliebigen Typs



Und so funktionierts:



Vorarbeit

1. Laden Sie sich die erforderliche JavaScript-Datei herunter: Helpesign.zip

2. Entpacken Sie Helpesign.zip in ein beliebiges Verzeichnis

3. Öffnen Sie ein Help & Manual-Projekt

4. Fügen Sie die HelpDesign.js zum Projekt hinzu: Menü Project > Project Properties > Common Properties > Baggage Files > Add File > Dateityp > All files > HelpDesign.js wählen > Öffnen > OK



Umsetzung

1. Einen Topic öffnen oder einen neuen Topic anlegen

2. In diesem Topic den Pfad zur HelpDesign.js eintragen: Menü Insert > HTML Plain Code > folgenen Code eingeben:

Code: Alles auswählen

<script language="JavaScript" src="HelpDesign.js"></script>
> OK

3. Im Topic den Cursor an der Stelle platzieren, an der der Link auf die externe Datei hinterlegt werden soll

4. Über Menü Insert > HTML Plain Code > folgenen Code eingeben:

Code: Alles auswählen

<a onclick="parser&#40;'Manual.pdf'&#41;" style="text-decoration&#58; underline; color&#58; green; cursor&#58; hand">Link auf n externes PDF</a>
> OK

5. Das blaue <a-Element doppelklicken

6. Den Dateinamen im Ausdruck ('Manual.pdf') durch den Dateinamen der tatsächlichen Datei ersetzen

7. Das saloppe Link auf n externes PDF durch einen seriösen Text ersetzen. Dabei handelt es sich um den Linktext > OK.

8. Alles speichern

9. .chm generieren

10. Die externe Datei in das Verzeichnis kopieren, in der sich die generierte .chm-Datei befindet.

WICHTIG: Diese externen Dateien müssen im selben Verzeichnis wie die .chm liegen, sonst funktionierts nicht.

11. .chm öffnen, Link klicken und staunen ...



Zum Nachlesen die Original-Quelle: http://msdn2.microsoft.com/en-us/librar ... 690.aspx[b][/b]
Zuletzt geändert von Jörg Ertelt am Di Apr 18, 2017 19:28, insgesamt 4-mal geändert.
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Lizenzen kaufen / upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HELPDESIGN • JÖRG ERTELT
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

pit2008
Beiträge: 17
Registriert: Sa Nov 15, 2008 21:46

schäm mich fast diese einfache Lösung zu schreiben

Beitrag von pit2008 »

Das mit dem Script hat bei mir nicht geklappt.

Habs mit HTML probiert ...

-> Edit HTML Code ....

a href="file://Server/kurzliste.pdf">Kurze Liste</a>"

- > ok.

File erstellen, geht perfekt.



Vor dem A noch eine < kann ich hier im Forum nicht einfügen sonst verschwindet die Zeile

Benutzeravatar
Jörg Ertelt
Moderator
Beiträge: 2646
Registriert: Do Dez 22, 2005 21:28

Beitrag von Jörg Ertelt »

==

a href="file://Server/kurzliste.pdf">Kurze Liste</a>"

- > ok.

File erstellen, geht perfekt

==



Mhm. Das "file://Server/kurzliste.pdf" ist ein absoluter Link. Auf einem anderen Rechner wird das nicht funktionieren, weil der Pfad nicht vorhanden ist. Das Skript hingegen setzt den absoluten Pfad zu Laufzeit zusammen. Deshalb ist es dann egal, wo sich die Zieldatei befindet.



BTW: Das Skript funktioniert sehr wohl. Ich habe ein kleine Help & Manual 5-Projekt erstellt und hochgeladen. Download hier.



Im _Output-Ordner befindet sich eine .chm- und .pdf-Datei. .chm starten und die Links klicken.



==

Vor dem A noch eine < kann ich hier im Forum nicht einfügen sonst verschwindet die Zeile

==



Im Forum kann auch HTML-Code veröffentlicht werden. Einfach unterhalb des Editor-Fenster die Option HTML in diesem Beitrag deaktivieren ankreuzen.
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Lizenzen kaufen / upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HELPDESIGN • JÖRG ERTELT
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

juliank
Beiträge: 7
Registriert: Di Mai 05, 2015 17:49

Beitrag von juliank »

Hallo Forum,
ich muss aus einer chm-Datei einen Link auf eine PDF-Datei setzen. Diese Datei ist aber nicht im chm-Verzeichnis, sondern in einem Unterordner. Ist das irgendwie möglich?
Danke für Tipps, Julian

Benutzeravatar
Jörg Ertelt
Moderator
Beiträge: 2646
Registriert: Do Dez 22, 2005 21:28

Beitrag von Jörg Ertelt »

Guten Tag juliank,

Ist schon eine Weile her, dass ich mich in dieser Weise mit dem veralteten CHM beschäftigt habe - deshalb kann ich aus dem Stegreif keine Antwort geben.

Ich schlage vor, dass Sie das ausprobieren. Der Weg, aus einer CHM z. B. PDFs zu öffnen, ist Eingangs beschrieben. Sie müssen lediglich einen Pfad in ein Unterverzeichnis angeben - sprich zum Speicherort der CHM. Wenn diese und das PFD im selben Verzeichnis liegen, sind die Grundvoraussetzungen schon mal nicht schlecht.
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Lizenzen kaufen / upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HELPDESIGN • JÖRG ERTELT
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Krautkopf
Beiträge: 1
Registriert: Fr Mai 15, 2020 17:31

Re: Externe Dateien aus .chm-Dateien öffnen

Beitrag von Krautkopf »

Ich möchte diesen alten thread noch mal beleben.
Der beschriebene Weg über das Skript ist hilfreich und funktioniert.
Ich möchte aber auch aus meiner *.chm auf Dateien verlinken die in einem anderen Verzeichnis als die kompilierte *.chm stehen.
Der Pfad soll dabei relativ bleiben, damit es egal ist wo mein Programm installiert ist.
Meine Frage: gibt es dafür mittlerweile eine Lösung (HelpandManual Ver. 6)?
Wenn nein - bietet die neueste Version von H&M diese Möglichkeit?

Antworten