PDF-Export: Einzelne Zeichen verschwinden

Adobe PDF
Antworten
Benutzeravatar
Steff
Beiträge: 13
Registriert: Di Mai 27, 2014 10:31

PDF-Export: Einzelne Zeichen verschwinden

Beitrag von Steff »

Hallo,

wenn ich Dokumente als PDF publiziere, gehen bestimmte Sonderzeichen verloren.
Das Problem tritt aktuell auf bei alten Help & Manual 6 Dokumenten, die nun mit Help & Manual 7 publiziert werden.

Zwei Screenshots zur Verdeutlichung:

1. PDF, publiziert mit Help & Manual 6 => korrekte Anzeige aller Zeichen:

Bild

2. Das selbe PDF, publiziert mit Help & Manual 7 => diverse Zeichen fehlen

Bild

Ich vermute, das Problem hat damit zu tun, wie Schriften in Help & Manual eingebunden sind.

Insgesamt gibt es Dokumente mit 3 verschiedenen Schriftvarianten:

* Dokumente, wo Arial verwendet wird (und wahrscheinlich einfach die Standard-Einstellung übernommen wurde)
* Dokumente, wo die Schrift auf eine Helvetica geändert wurde
* Dokumente, wo eine spezielle Hausschrift verwendet wird

=> Beim Öffnen und Exportieren mit Help & Manual 6 werden bei allen 3 Varianten korrekte PDFs mit allen Zeichen erzeugt.
=> Beim Öffnen und Exportieren mit Help & Manual 7 werden nur die Dokumente mit Helvetica korrekt angezeigt. Das sind gleichzeitig, diejenigen Dokumente, die schon länger mit Help & Manual 7 bearbeitet (vielleicht sogar erstellt) wurden.

==> Irgendwie scheint bei diesem Dokument die zu verwendende Helvetica-Schrift auf eine Art korrekt eingebunden worden zu sein, die bei den Dokumenten mit anderer Schrift fehlt (dort aber nicht zu Problemen geführt hat, solange ich mit Version 6 gearbeitet habe).

Ergibt meine Schlussfolgerung Sinn?
Was könnte ich als nächstes probieren?

Ich habe die Einstellungen unter "Font Embedding" und "PDF Export" angesehen. Diese sind aber überall identisch.

* Bei Font Embedding:
Font Mode: Embed True Type fonts

* Bei Program Options > PDF Export:
"Use screen as reference device"
Zuletzt geändert von Steff am Mi Okt 17, 2018 15:46, insgesamt 1-mal geändert.

Benutzeravatar
Jörg Ertelt
Moderator
Beiträge: 2663
Registriert: Do Dez 22, 2005 21:28

Beitrag von Jörg Ertelt »

Guten Tag Steff,

Prüfen Sie zunächst, ob Sie die aktuelle H+M-Version installiert haben:
Menüband Hilfe > Webhelp > Updates prüfen.
Falls nicht, Update herunterladen und installieren, dann prüfen, ob es eine Verbesserung gibt.

Falls nicht, folgendes probieren:
Konfiguration > Exporteinstellungen > Adobe PDF > "Eingebettete Schriften":
• Schriftpakete als Type3 einbetten
• Symbolschriften als Grafiken einbetten
Diese Optionen helfen sehr oft weiter in solchen Fällen.
Danach sollte er in dieser Reihenfolge folgende Einbettungsoptionen versuchen:
• CID einbetten
• Type3 einbetten
Type3 sollte eigentlich immer funktionieren, wobei die Schrift u.U. minimal weniger scharf wirken kann. Es ist aber z.B. die zuverlässigste Lösung, wenn man Latin und Asian Fonts mischt.

Falls es dann immer noch klemmt: Melden.
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Lizenzen kaufen / upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HELPDESIGN • JÖRG ERTELT
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Benutzeravatar
Steff
Beiträge: 13
Registriert: Di Mai 27, 2014 10:31

Beitrag von Steff »

Es scheint, dass ich das Problem nun lösen konnte durch Deaktivieren der Option:
  • Configuration > Publishing Options > Adobe PDF > Font Embedding > "Export Symbol text as glyphs"
Vielen Dank für die Hilfe
Steff Heller

Benutzeravatar
Jörg Ertelt
Moderator
Beiträge: 2663
Registriert: Do Dez 22, 2005 21:28

Beitrag von Jörg Ertelt »

ok
Viele Grüße

Jörg Ertelt

HELP+MANUAL
:: Lizenzen kaufen / upgraden
:: Offene und Firmenseminare

SUPPORT
:: Help+Manual-Forum
:: Help+Manual-Knowledgebase

HELPDESIGN • JÖRG ERTELT
Ulrichstraße 1
D-73240 Wendlingen am Neckar
www.helpdesign.eu

Benutzeravatar
lumizil
Beiträge: 17
Registriert: Fr Feb 21, 2014 09:31

Beitrag von lumizil »

Hallo Steff,

ggf. hilft auch das erzeugen eines neuen Stil.

über Einfügen -> Formate -> Formate bearbeiten

Hier eine neues Format anlegen mit dem Zeichensatz der dieses Symbol beinhaltet. Im Anschluss den entsprechenden Topic-Text (das Symbol) mit diesem neuen Format Stil setzen. Danach, wenn nicht im Export ausgeklammert, wird der Zeichensatz sicher in das PDF eingebettet und angezeigt.

Antworten